Web Wiz - Solar Powered Eco Hosting

  New Posts New Posts RSS Feed - Cannot connect to database
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Cannot connect to database

 Post Reply Post Reply
Author
markt View Drop Down
Newbie
Newbie


Joined: 13 May 2010
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote markt Quote  Post ReplyReply Direct Link To This Post Topic: Cannot connect to database
    Posted: 13 May 2010 at 7:08pm
Hi I'm having problems connecting to the sql server database using client tools (Management Studio, and Visual Web developer)

Research on the web suggested trying to isolate the problem as follows:

Ping mssql2.sqllive.co.uk - works and returns IP 84.45.57.66

Tracert mssql2.sqllive.co.uk - works after firewall turned off

Telnet mssql2.sqllive.co.uk - fails with "Could not open connection to host, on port 23 Connection Failed" Message

Adding a connection in VWD or Management Studio gives an error stating that the connection failed.

Clearly there must be a configuration problem somewhere in my setup (XP Pro) but I've exhausted all the areas I can find to diagnose the problem. Please could you advise areas I could try.

Thanks in advance

Mark
Back to Top
WebWiz-Bruce View Drop Down
Admin Group
Admin Group
Avatar
Web Wiz Developer

Joined: 03 September 2001
Location: Poole
Status: Offline
Points: 9526
Post Options Post Options   Thanks (0) Thanks(0)   Quote WebWiz-Bruce Quote  Post ReplyReply Direct Link To This Post Posted: 14 May 2010 at 11:09am
Make sure you have opened port 1433 on your Firewall so you can connect to the database server on the default port for SQL Server.
Back to Top
markt View Drop Down
Newbie
Newbie


Joined: 13 May 2010
Status: Offline
Points: 3
Post Options Post Options   Thanks (0) Thanks(0)   Quote markt Quote  Post ReplyReply Direct Link To This Post Posted: 14 May 2010 at 6:19pm
Iv'e turned all the firewalls off to test this router, windows and Avast!
Back to Top
WebWiz-Bruce View Drop Down
Admin Group
Admin Group
Avatar
Web Wiz Developer

Joined: 03 September 2001
Location: Poole
Status: Offline
Points: 9526
Post Options Post Options   Thanks (0) Thanks(0)   Quote WebWiz-Bruce Quote  Post ReplyReply Direct Link To This Post Posted: 17 May 2010 at 9:16am
Check with your ISP that they do not block port 1433 used by SQL Server. Some ISP's block this port on home broadband packages.
Back to Top
Edwerd View Drop Down
Newbie
Newbie
Avatar

Joined: 04 November 2010
Location: UK
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote Edwerd Quote  Post ReplyReply Direct Link To This Post Posted: 04 November 2010 at 11:10am
Did you tried to connect with your database using Sql server management studio, if it’s work, problem is in your VWD. Try to uninstall and reinstall it. Good luck.
Back to Top
jonathan cole View Drop Down
Newbie
Newbie


Joined: 18 February 2011
Status: Offline
Points: 8
Post Options Post Options   Thanks (0) Thanks(0)   Quote jonathan cole Quote  Post ReplyReply Direct Link To This Post Posted: 04 April 2011 at 11:27am
try once again with port 1433 and if it is  not ok reinstall that.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.01
Copyright ©2001-2018 Web Wiz Ltd.


Become a Fan on Facebook Follow us on Twitter Connect with us on LinkedIn Community Forums Web Wiz Blogs Web Wiz News
About Web Wiz | Contact Web Wiz | Terms & Conditions | Cookies | Privacy Policy

Web Wiz is the trading name of Web Wiz Ltd. Company registration No. 05977755. Registered in England and Wales.
Registered office: Web Wiz Ltd, Unit 18, The Glenmore Centre, Fancy Road, Poole, Dorset, BH12 4FB, UK.

Prices exclude VAT unless otherwise stated. VAT No. GB988999105 - $, € prices shown as a guideline only.

Copyright ©2001-2019 Web Wiz Ltd. All rights reserved.