Web Wiz

  New Posts New Posts RSS Feed - mySQL upgrading - 500 - Internal server erro
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

mySQL upgrading - 500 - Internal server erro

 Post Reply Post Reply Page  <12
Author
slappyJ View Drop Down
Groupie
Groupie
Avatar

Joined: 28 January 2004
Status: Offline
Points: 156
Post Options Post Options   Thanks (0) Thanks(0)   Quote slappyJ Quote  Post ReplyReply Direct Link To This Post Posted: 22 June 2018 at 9:52pm
I am now able to get more detailed error messages.

But, I am still getting hung up on the database folder not writeable error.

I have enabled read and write permissions in FileZilla to the database folder and also changed permissions to the database folder through Windows 7.

I can test the database connection with no errors but cannot proceed.

This link shows:

Checking and Setting up the Correct Permissions on the IIS Server

https://www.webwiz.net/kb/asp_knowledgebase/server_permissions.asp

In Windows 7 I added a group IIS_IUSRS (computername\IIS_IUSRS) with full control permissions and uploaded but still cannot proceed with the update.

The frustration continues. Confused

Back to Top
WebWiz-Bruce View Drop Down
Admin Group
Admin Group
Avatar
Web Wiz Developer

Joined: 03 September 2001
Location: Poole
Status: Offline
Points: 9493
Post Options Post Options   Thanks (0) Thanks(0)   Quote WebWiz-Bruce Quote  Post ReplyReply Direct Link To This Post Posted: 25 June 2018 at 3:13pm
You can not set permissions through FTP on a Windows server, you can only do this on a Unix/Linux server, so setting permissions in FilZilla FTP client would notwork.

Permissions need to be set directly on the server or if using a web host thy usually have a way to do this through the hosting control panel.

You need to set read and write permissions on the 'database' folder for the user that the websites application pool runs under.

If you are using application pass through rather than setting a specific user try setting the permission for the 'IUSR' account.
Back to Top
slappyJ View Drop Down
Groupie
Groupie
Avatar

Joined: 28 January 2004
Status: Offline
Points: 156
Post Options Post Options   Thanks (0) Thanks(0)   Quote slappyJ Quote  Post ReplyReply Direct Link To This Post Posted: 26 June 2018 at 4:01am
I managed to get the Database Setup Wizard to complete. (For future reference to anybody else having similar issues I was able to set read write permissions to the database folder through my hosts control panel...thank you Bruce).

Checking database. Please be patient as this may take a few minutes to complete.

Congratulations, Web Wiz Forums Database setup is now complete


But, now when I try to access the homepage www.kleenkuip.com/forum I get redirected to a 404 error page located here:http://kleenkuip.com/forum/forums.html

Is this a problem with my host? All the relevant files within the forum folder are where they should be.
Back to Top
WebWiz-Bruce View Drop Down
Admin Group
Admin Group
Avatar
Web Wiz Developer

Joined: 03 September 2001
Location: Poole
Status: Offline
Points: 9493
Post Options Post Options   Thanks (0) Thanks(0)   Quote WebWiz-Bruce Quote  Post ReplyReply Direct Link To This Post Posted: 26 June 2018 at 8:09am
It looks there is an issue with the URL Rewriting.

Check with your web host they have the IIS URL Rewrite Mod installed on the server and that you do not have URL Rewrite rules that are conflicting in your websites root web.config file.

If you have conflicting URL Rewrite rules in your websites root web.config you would need to move the forum to it's own website so they do not conflict. A sub domain websites such as forum.kleenkuip.com would be fine.

The other option is to disable the forums URL Rewriting features. To do this remove the forums web.config file and then login to the admin area by going to the /admin.asp page of the forum and from the SEO section disable URL Rewriting.

Remember as well browsers cache redirects so after any changes you may need to use a different browser or reboot your computer to flush any cached redirects from your browser.


Edited by WebWiz-Bruce - 27 June 2018 at 7:40am
Back to Top
slappyJ View Drop Down
Groupie
Groupie
Avatar

Joined: 28 January 2004
Status: Offline
Points: 156
Post Options Post Options   Thanks (0) Thanks(0)   Quote slappyJ Quote  Post ReplyReply Direct Link To This Post Posted: 27 June 2018 at 4:36am
The issue has finally been resolved!

The solution was to delete the web.config file.

Thanks for all your help Bruce. Thumbs Up
Back to Top
 Post Reply Post Reply Page  <12
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.01
Copyright ©2001-2018 Web Wiz Ltd.


Become a Fan on Facebook Follow us on Twitter Find us on Google+ Community Forums Web Wiz Blogs Web Wiz News
About Web Wiz | Contact Web Wiz | Terms & Conditions | Cookies | Privacy Policy

Web Wiz is the trading name of Web Wiz Ltd. Company registration No. 05977755. Registered in England and Wales.
Registered office: Web Wiz Ltd, Unit 18, The Glenmore Centre, Fancy Road, Poole, Dorset, BH12 4FB, United Kingdom.

Prices exclude VAT unless otherwise stated. VAT No. GB988999105 - $, € prices shown as a guideline only.

Copyright ©2001-2018 Web Wiz Ltd. All rights reserved.