Print Page | Close Window

HTTP Error 500.19 - 0x8007000d

Printed From: Web Wiz Forums
Category: Web Wiz Web App Support Forums
Forum Name: Web Wiz Forums
Forum Description: Support forum for Web Wiz Forums application.
URL: https://forums.webwiz.net/forum_posts.asp?TID=31666
Printed Date: 29 November 2020 at 3:48pm
Software Version: Web Wiz Forums 12.03 - http://www.webwizforums.com


Topic: HTTP Error 500.19 - 0x8007000d
Posted By: WizzRa
Subject: HTTP Error 500.19 - 0x8007000d
Date Posted: 06 March 2020 at 4:46pm
Testing the forum software on a Window Server 2016 virtual machine.

Having the above error.
The instructions (whilst not very detailed) state to make sure IIS is installed with ASP classic which I;ve done.

Also set the IIS user to have modify rights on the database folder.

Are there any other settings that need to be enabled in IIS?

If I copy the file to Azure Application service, the forum setup works fine so it cannot be an issue with the file web.config file as per the error message and I miust be missing an IIS setting that's not mentioned in the guide.

Appreciate any assistance.



Replies:
Posted By: WebWiz-Bruce
Date Posted: 06 March 2020 at 4:49pm
Error looks to relate to the URL Rewrite Rules in the web.config file.

Install the IIS URL Rewrite module on the server and it should fix the error for you.

You can download it from the page below;

https://www.iis.net/downloads/microsoft/url-rewrite" rel="nofollow - https://www.iis.net/downloads/microsoft/url-rewrite


-------------
http://www.facebook.com/WebWiz" rel="nofollow - Find Web Wiz on Facebook
http://twitter.com/WebWizUK" rel="nofollow - Follow Web Wiz on Twitter


Posted By: WizzRa
Date Posted: 06 March 2020 at 4:54pm
Originally posted by WebWiz-Bruce WebWiz-Bruce wrote:

Error looks to relate to the URL Rewrite Rules in the web.config file.

Install the IIS URL Rewrite module on the server and it should fix the error for you.

You can download it from the page below;

https://www.iis.net/downloads/microsoft/-re - https://www.iis.net/downloads/microsoft/url-rewrite

Awesome fella !!

That fixed it ... and thanks very much for the quick reply!

Did I miss that instruction anywhere?. Swear I never say it published.


Posted By: WebWiz-Bruce
Date Posted: 06 March 2020 at 5:03pm
The web.config file with the URL rewrite rules use to be a separate download, but as most servers already have URL Rewrite installed it is now included in the main download.

The documentation needs to be updated in case there are people like yourself that might not have installed it.

Not sure why Microsoft don'y include URL Rewrite as a built in module. As it is something that everyone installs as almost every website and application uses it.


-------------
http://www.facebook.com/WebWiz" rel="nofollow - Find Web Wiz on Facebook
http://twitter.com/WebWizUK" rel="nofollow - Follow Web Wiz on Twitter


Posted By: WizzRa
Date Posted: 06 March 2020 at 5:14pm
Understood ... thanks for the assistance !


Posted By: WizzRa
Date Posted: 07 March 2020 at 8:52am
Sir Bruce .... perhaps you can help with one more thing, connection to the DB.

During setup, there is an extra option compared to the guide screenshot, The SQL database driver option.

I have another VM with SQL server 2017 installed.
Installed the MDAC on the web server VM.
Created a blank DB with the name "webwizforum".

Selecting the native client v11 option produces "adodb.connection provider cannot be found" errors.
Selecting the OLE DB option produces "[DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied."

The SA account is disabled by default on installation.
Created another database account but not sure what permissions are required or if there are other missing packages that are not mentioned?

Any ideas please?


Posted By: WebWiz-Bruce
Date Posted: 09 March 2020 at 7:52am
The error means the database driver is not installed on the web server, select the other database driver, or install the 'SQL Server Driver SQL Server Native Client 11.0' on the web server.

-------------
http://www.facebook.com/WebWiz" rel="nofollow - Find Web Wiz on Facebook
http://twitter.com/WebWizUK" rel="nofollow - Follow Web Wiz on Twitter


Posted By: WizzRa
Date Posted: 10 March 2020 at 11:52am
Installed the DB driver on the Web VM.

Had an error for Named Pipes. Therefore enabled that and TCP/IP settings in Config Mgr but still had same error. Realised a Win FW rule was not created for SQL server on install so created that and did a telnet test to port 1433 which partially resolves the connection bit.

It appears the authentication is now as issue.
The DB name is "WebWizForums"
Trying to give the SA user DB Owner rights fails.
Creating a new DB user called "WebWiz" allows me to make it DB owner but not sure what else is needed.

I'm going to spin up another VM with SQL Express to see if that works and figure out what user settings it uses .... unless you can advise what steps are needed for a new DB user to authentgicate to a fresh DB which I can try to replicate?

Cheers 


Posted By: WebWiz-Bruce
Date Posted: 10 March 2020 at 1:31pm
I always rename the SA user account and this comes under constant brute force password attacks if the database server is connected to the Internet.

It is always best to create a new user and set that new database user as the DB Owner over the Web Wiz Forums database so that it can create a modify database objects.

If installing SQL Server Express install it in mixed mode with TCP/IP connections enabled. Also important with SQL Server Express change it to be the 'Default Instance' so that you are not having to mess around with a named instance.


-------------
http://www.facebook.com/WebWiz" rel="nofollow - Find Web Wiz on Facebook
http://twitter.com/WebWizUK" rel="nofollow - Follow Web Wiz on Twitter


Posted By: WizzRa
Date Posted: 12 March 2020 at 5:31pm
Unfortunately I can't get this to work even with SQL Express installed on a different VM or the same VM as the Forum.

I created a new user called "websa" using SQL Authentication in Security/Logins. In the propeties I go to USer Mapping and tick the WebWizForum database. By default the user is "websa" and no deafult schema so I set it to DBO.

This user then appears in Databases/WebWizForums/Security/Users. From here I've set DB_Owner in Owned Schema and Memberships.

Shared Memory, Named Pipes and TCP/IP all enabled. Windows firewall allows 1433 inbound and can telnet test successfully .... But no Coconut.


Posted By: WebWiz-Bruce
Date Posted: 13 March 2020 at 3:46pm
Have you used SQL Server Configuration Manager  to enable TCP/IP under SQL Server Network Configuration for the IP address you are connecting too?

By default TCP/IP is disabled for SQL Server unless you manually enable it.


-------------
http://www.facebook.com/WebWiz" rel="nofollow - Find Web Wiz on Facebook
http://twitter.com/WebWizUK" rel="nofollow - Follow Web Wiz on Twitter


Posted By: WizzRa
Date Posted: 16 March 2020 at 5:02pm
Hi Bruce, 

Yes that's already enabled.


Posted By: WebWiz-Bruce
Date Posted: 17 March 2020 at 8:21am
What error message to you get?

-------------
http://www.facebook.com/WebWiz" rel="nofollow - Find Web Wiz on Facebook
http://twitter.com/WebWizUK" rel="nofollow - Follow Web Wiz on Twitter


Posted By: WizzRa
Date Posted: 17 March 2020 at 9:29am
Regardless of the driver I use (OLE DB or Native client) the error is:

" Login failed from user 'webwiz' ".

Where webwiz is the database user created.

I can upload screenshots and provide URL links later this morning so you may spot something I may have missed


Posted By: WebWiz-Bruce
Date Posted: 17 March 2020 at 12:03pm
You mentioned previously the SQL Server database user you created with access to the database was "websa".

In your error message is says that you are using the username "webwiz" in your database connection.

If the SQL Server database user you created is "websa" then you should be using this user to connect to the database from Web Wiz Forums.


-------------
http://www.facebook.com/WebWiz" rel="nofollow - Find Web Wiz on Facebook
http://twitter.com/WebWizUK" rel="nofollow - Follow Web Wiz on Twitter


Posted By: WizzRa
Date Posted: 17 March 2020 at 1:49pm
Indeed, that was the config I used previously but have since blitzed that VM (due to cloning errors I spotted) and went with a fresh install using webwiz now as the username, as well as re-implementing all the components you've mentioned on the fresh Win Server install.

Away from my lab but will post screenies bit later today.


Posted By: WebWiz-Bruce
Date Posted: 17 March 2020 at 3:27pm
The error would indicate one of the following;

1. The password for the SQL Server user is incorrect
2. The SQL Server user does not have permission to access the database

Check you ha e the correct password and that in the SQL Server properties for the User that 'User Mappings' has the Web Wiz Forums database checked as well as 'db-owner' and 'public' role memberships on the database.


-------------
http://www.facebook.com/WebWiz" rel="nofollow - Find Web Wiz on Facebook
http://twitter.com/WebWizUK" rel="nofollow - Follow Web Wiz on Twitter


Posted By: WizzRa
Date Posted: 17 March 2020 at 5:04pm
Thanks.

I've gone over the pwd and definately using the right one.

https://i.imgur.com/7c71pgT.jpg
WEB config, based on the KB article.

https://i.imgur.com/H6a5fvK.jpg
DB, based on guidance here and other generic DB guides.

https://i.imgur.com/C8xbDH9.jpg
SQL Config, network config as mentioned here and client protocol support also enabled here. And installed in the Web Server.

What else could I be missing or is there a glaring mistake in the screenies?


Posted By: WebWiz-Bruce
Date Posted: 17 March 2020 at 5:12pm
In your last screenshot in SQL Server Configuration Manager 'Enabled' is set to 'No' next to each of the IP addresses.

This 'Enabled' needs to be set to 'Yes' for the IP 192.168.0.20 which you are using to connect to the database.

Once you have set it to 'Yes' for the IP you should restart SQL Server so that the settings take affect.


-------------
http://www.facebook.com/WebWiz" rel="nofollow - Find Web Wiz on Facebook
http://twitter.com/WebWizUK" rel="nofollow - Follow Web Wiz on Twitter


Posted By: WizzRa
Date Posted: 17 March 2020 at 5:25pm
OK ... so I misunderstood previous guidance was simply to set TCP/IP to enabled. I have now enabled YES for the IP address and re-tested which still didnt work. Enabled YES on all interfaces just for a laugh but no joy. Suggestions?

Also, can you confirm if the WEB config is correct based on the DB config screenshot?


Posted By: WebWiz-Bruce
Date Posted: 18 March 2020 at 11:00am
Sorry pout of suggestions.

The web.config is only used for rewrite rules in Web Wiz Forums.

The files in the 'database' folder are used in Web Wiz Forums for the database connection.


-------------
http://www.facebook.com/WebWiz" rel="nofollow - Find Web Wiz on Facebook
http://twitter.com/WebWizUK" rel="nofollow - Follow Web Wiz on Twitter


Posted By: WizzRa
Date Posted: 22 March 2020 at 9:28am
FYI ... Got it working.
Spun up a fresh Win19K VM with a SQL17K.

Allied all the usual changes including the guidance mention throughout this thread. Still had the same Auth error issue .... but this time I changed the actual server properties (not just at the DB level) which by default ony allows Windows Auth instead of mixed mode.

Had a minor new issue with the /forum/database folder permissions. I did set the IIS user to read/write/mod ... but kept failing to update the config file during setup. Had to temporarily add the Everyone group with FULL permissions to get it to work before removing the group again. This could be because the default file perms for Windows Server 2016+ is different to older versions of the OS and certainly different to client OS (Win 7 and above) which has the Authenticated Users groups in there etc.

I've captured a set of bullets to get it working on an isolation environment like mine if you want to poilish up the out of dat KB.

Thanks for all your heklp Bruce!



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.03 - http://www.webwizforums.com
Copyright ©2001-2019 Web Wiz Ltd. - https://www.webwiz.net