Print Page | Close Window

forums.html not working (404 error)

Printed From: Web Wiz Forums
Category: Web Wiz Web App Support Forums
Forum Name: Web Wiz Forums
Forum Description: Support forum for Web Wiz Forums application.
URL: https://forums.webwiz.net/forum_posts.asp?TID=31746
Printed Date: 05 October 2022 at 10:22am
Software Version: Web Wiz Forums 12.05 - http://www.webwizforums.com


Topic: forums.html not working (404 error)
Posted By: MPIDR
Subject: forums.html not working (404 error)
Date Posted: 16 June 2022 at 5:17pm
Dear all,

Web Wiz Forum 12.05 has been installed from scratch. URL Rewrite was on that server already. I can see that the WWF installation routing created a number of URL rewrite rules. Despite that, we see a 404 error after logging off for the URL ending with /forums.html. 

I already tried this hint from another post but enabling URL rewriting as part of the SEO config is not working: "To use URL Rewriting make sure you have the IIS URL Rewrite Module installed on the web server and enable 'URL Rewriting' enabled in the SEO page in the admin area."

Is there a way to fix this?

Regards,
MPIDR



Replies:
Posted By: WebWiz-Bruce
Date Posted: 17 June 2022 at 7:26am
Is the URL rewriting working for other parts of your forum? If it is then viewing forums and topics should rewrite the URL with a .html page name rather than .asp. 

Is the place you are redirected with the page name 'forum.htm' when you logoff in the same folder as Web Wiz Forums is installed?


-------------
http://www.facebook.com/WebWiz" rel="nofollow - Find Web Wiz on Facebook
http://twitter.com/WebWizUK" rel="nofollow - Follow Web Wiz on Twitter


Posted By: MPIDR
Date Posted: 17 June 2022 at 9:02am
When viewing a forum, I see an .html page, e.g. https://server.com/forum/forum-1-1_forum1.html. Viewing a topic is also .html, e.g. https://server.com/forum/topic1_post1.html#1. 

WWF is installed at https://server.com/forum. When I log off, the URL changes to https://server.com/forum/forums.html. So this seems to be correct.


Posted By: MPIDR
Date Posted: 17 June 2022 at 9:02am
"So this seems to be correct."
In the sense of the correct path. I still get the 404.


Posted By: WebWiz-Bruce
Date Posted: 17 June 2022 at 2:51pm
Please check that you have the following in your forums web.config file;

<rule name="default 5">
    <match url="^default\.asp(.*)" ignoreCase="true" />
    <action type="Redirect" url="forums.html" redirectType="Permanent" />
</rule>
<rule name="default 6" stopProcessing="true">
    <match url="^forums\.html" ignoreCase="true" />
    <action type="Rewrite" url="default.asp" />
</rule>


If you do then the rewrite is set correctly and the only other explanation is a configuration setting on your server or web application firewall that could be blocking the request.


-------------
http://www.facebook.com/WebWiz" rel="nofollow - Find Web Wiz on Facebook
http://twitter.com/WebWizUK" rel="nofollow - Follow Web Wiz on Twitter


Posted By: MPIDR
Date Posted: 17 June 2022 at 3:29pm
Yes, these lines are in /forum/web.config. So the WWF installation went well. I will check if installing a later version of the URL Rewrite module will help.


Posted By: MPIDR
Date Posted: 20 June 2022 at 10:53am
Installing the URL Rewrite module v2.1 helped. I am not sure if it was v2.0 before and upgrading solved the issue or if it was v2.1 already and the re-installation made things work.


Posted By: WebWiz-Bruce
Date Posted: 20 June 2022 at 3:49pm
That great news that installing or reinstalling URL Rewrite 2.1 fixed the issue

-------------
http://www.facebook.com/WebWiz" rel="nofollow - Find Web Wiz on Facebook
http://twitter.com/WebWizUK" rel="nofollow - Follow Web Wiz on Twitter


Posted By: barrisoul
Date Posted: 15 July 2022 at 8:30am
interesting information 



Print Page | Close Window

Forum Software by Web Wiz Forums® version 12.05 - http://www.webwizforums.com
Copyright ©2001-2022 Web Wiz Ltd. - https://www.webwiz.net