Web Wiz - Solar Powered Eco Web Hosting

  New Posts New Posts RSS Feed - Server Variables
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Server Variables

 Post Reply Post Reply
Author
bsafsbc View Drop Down
Newbie
Newbie


Joined: 07 February 2022
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote bsafsbc Quote  Post ReplyReply Direct Link To This Post Topic: Server Variables
    Posted: 07 February 2022 at 3:29am
I'm trying to reuse an old legacy application using Classic ASP and after installing it and setting up the MySQL database all is ALMOST working correctly.  But I get a fatal server error (500) without explanation when my code tries to set a session variable.  I've been able to see that everything else pretty much works - it just acts kind of funny because this variable is missing.  

Any ideas why this is generating an error - and what I can do to fix it?
Back to Top
WebWiz-Bruce View Drop Down
Admin Group
Admin Group
Avatar
Web Wiz Developer

Joined: 03 September 2001
Location: Poole
Status: Offline
Points: 9730
Post Options Post Options   Thanks (0) Thanks(0)   Quote WebWiz-Bruce Quote  Post ReplyReply Direct Link To This Post Posted: 07 February 2022 at 3:25pm
Are you hosting the website with Web Wiz? If you are you can enabled detailed error messages Classic ASP from the control panel, see page below for further details;

https://www.webwiz.net/kb/controlpanel-tutorials/enable-detailed-error-messages.htm

If you are hosting the website with another provider you may need to enable detailed error messages through the web.config file by adding the following to the system.webServer section;

<system.webServer>
    <httpErrors errorMode="Detailed" />
</system.webServer>

If you are hosting with Web Wiz and need further help, please open a support ticket at www.webwiz.net/support 
Back to Top
bsafsbc View Drop Down
Newbie
Newbie


Joined: 07 February 2022
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote bsafsbc Quote  Post ReplyReply Direct Link To This Post Posted: 08 February 2022 at 9:06pm
Yes, it is hosted on WebWiz.  And the error I get is shown below.  The option in Web.Config to see all errors is already set.  And I have gone through the control panel setup.  I do get other errors properly displayed when they occur as I'm trying to re-launch this application.  Only the action of setting a session variable causes this error:

"Session Variables SetAn error occurred on the server when processing the URL. Please contact the system administrator.

If you are the system administrator please click  https://go.microsoft.com/fw/?ID=82731 - here to find out more about this error."

Back to Top
bsafsbc View Drop Down
Newbie
Newbie


Joined: 07 February 2022
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote bsafsbc Quote  Post ReplyReply Direct Link To This Post Posted: 08 February 2022 at 9:45pm
Forgot to mention - the first part "Session Variables Set" is a tracer line I inserted in the code before the session set.  It didn't get to the tracer I set several lines after.


Back to Top
 Post Reply Post Reply

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.05
Copyright ©2001-2022 Web Wiz Ltd.


Become a Fan on Facebook Follow us on Twitter Connect with us on LinkedIn Web Wiz Blogs
About Web Wiz | Contact Web Wiz | Terms & Conditions | Cookies | Privacy Policy

Web Wiz is the trading name of Web Wiz Ltd. Company registration No. 05977755. Registered in England and Wales.
Registered office: Web Wiz Ltd, Unit 18, The Glenmore Centre, Fancy Road, Poole, Dorset, BH12 4FB, UK.

Prices exclude VAT unless otherwise stated. VAT No. GB988999105 - $, € prices shown as a guideline only.

Copyright ©2001-2022 Web Wiz Ltd. All rights reserved.