Web Wiz - Solar Powered Eco Web Hosting

  New Posts New Posts RSS Feed - Enabling HTTPS breaks forum
  FAQ FAQ  Forum Search   Events   Register Register  Login Login

Enabling HTTPS breaks forum

 Post Reply Post Reply Page  12>
Author
slappyJ View Drop Down
Groupie
Groupie
Avatar

Joined: 28 January 2004
Status: Offline
Points: 166
Post Options Post Options   Thanks (0) Thanks(0)   Quote slappyJ Quote  Post ReplyReply Direct Link To This Post Topic: Enabling HTTPS breaks forum
    Posted: 24 October 2019 at 9:35pm
I just recently purchased and enabled HTTPS certificate on my website but now my forum does not load.

I get a "404 - File or directory not found" error.

How do I fix this?

Thanks,
slappyJ
Back to Top
WebWiz-Bruce View Drop Down
Admin Group
Admin Group
Avatar
Web Wiz Developer

Joined: 03 September 2001
Location: Poole
Status: Offline
Points: 9585
Post Options Post Options   Thanks (0) Thanks(0)   Quote WebWiz-Bruce Quote  Post ReplyReply Direct Link To This Post Posted: 25 October 2019 at 8:14am
Are you using the latest version of Web Wiz Forums and have you enabled HTTPS support from the forum admin area?
Back to Top
slappyJ View Drop Down
Groupie
Groupie
Avatar

Joined: 28 January 2004
Status: Offline
Points: 166
Post Options Post Options   Thanks (0) Thanks(0)   Quote slappyJ Quote  Post ReplyReply Direct Link To This Post Posted: 25 October 2019 at 8:47pm
Yes, latest version.

Do I also have to change the "Web address path to forum*" option to reflect the https? or does this option stay the same?


Back to Top
WebWiz-Bruce View Drop Down
Admin Group
Admin Group
Avatar
Web Wiz Developer

Joined: 03 September 2001
Location: Poole
Status: Offline
Points: 9585
Post Options Post Options   Thanks (0) Thanks(0)   Quote WebWiz-Bruce Quote  Post ReplyReply Direct Link To This Post Posted: 28 October 2019 at 7:57am
It should be changed to HTTPS://
Back to Top
slappyJ View Drop Down
Groupie
Groupie
Avatar

Joined: 28 January 2004
Status: Offline
Points: 166
Post Options Post Options   Thanks (0) Thanks(0)   Quote slappyJ Quote  Post ReplyReply Direct Link To This Post Posted: 28 October 2019 at 8:10pm
Here's the problem I am having.

I made the change to load SSL in the Web Wiz options but when I hit the save button my browser gave me a 404 error.

Now when I try to access my forum I still get the 404 error. Doesn't matter if I change the main site to use SSL or not to use SSL I still get 404 error.
Back to Top
WebWiz-Bruce View Drop Down
Admin Group
Admin Group
Avatar
Web Wiz Developer

Joined: 03 September 2001
Location: Poole
Status: Offline
Points: 9585
Post Options Post Options   Thanks (0) Thanks(0)   Quote WebWiz-Bruce Quote  Post ReplyReply Direct Link To This Post Posted: 29 October 2019 at 1:37pm
It sounds like something is not setup correctly with SSL on your website as you should not get a 404 error message even if you have not enabled SSL support within Web Wiz Forums.

Contact your web host and ask them to have a look to see if the SSL is correctly setup on the website.
Back to Top
slappyJ View Drop Down
Groupie
Groupie
Avatar

Joined: 28 January 2004
Status: Offline
Points: 166
Post Options Post Options   Thanks (0) Thanks(0)   Quote slappyJ Quote  Post ReplyReply Direct Link To This Post Posted: 29 October 2019 at 8:42pm
I'm going to paste some text from my tech support...

It looks like Secure ASP was not enabled for your site. We've enabled it under Windows Services and now I'm getting different results.

When I access that link I'm getting redirected to an invalid URL "https://kleenkuip.com.ssl/forum/default.asp"
Do you have that address configured anywhere under the forum that might be causing a redirect?


Unfortunately to me it looks like the invalid redirect is in the forum settings somewhere.
I see that there was a test file under the same folder, which loads as expected using https now: https://www.kleenkuip.com/forum/helloworld.asp
Which indicates that the server configuration is correct.

Since I'm not familiar with that specific forum software I'm not too sure how you could check or fix a redirect if you can't get into it.
You should be able to edit a configuration file or database manually depending on where that setting is stored.


Back to Top
WebWiz-Bruce View Drop Down
Admin Group
Admin Group
Avatar
Web Wiz Developer

Joined: 03 September 2001
Location: Poole
Status: Offline
Points: 9585
Post Options Post Options   Thanks (0) Thanks(0)   Quote WebWiz-Bruce Quote  Post ReplyReply Direct Link To This Post Posted: 30 October 2019 at 9:30am
It looks like something in the unusual way your web host has setup SSL that the website name on the server has .SSL appended to the end.

Disable SSL support in Web Wiz Forums as it look like it is not compatible with the way your web host has implemented SSL on their system.
Back to Top
 Post Reply Post Reply Page  12>
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.03
Copyright ©2001-2019 Web Wiz Ltd.


Become a Fan on Facebook Follow us on Twitter Connect with us on LinkedIn Community Forums Web Wiz Blogs Web Wiz News
About Web Wiz | Contact Web Wiz | Terms & Conditions | Cookies | Privacy Policy

Web Wiz is the trading name of Web Wiz Ltd. Company registration No. 05977755. Registered in England and Wales.
Registered office: Web Wiz Ltd, Unit 18, The Glenmore Centre, Fancy Road, Poole, Dorset, BH12 4FB, UK.

Prices exclude VAT unless otherwise stated. VAT No. GB988999105 - $, € prices shown as a guideline only.

Copyright ©2001-2019 Web Wiz Ltd. All rights reserved.